Email Delays in North America for accounts using email V2
Incident Report for Stova
Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 10:21 EDT
Update
This incident has been resolved.
Posted Apr 02, 2024 - 09:56 EDT
Update
We are continuing investigation of a delay in sending outbound emails in North America for accounts using email V2.
Posted Apr 01, 2024 - 19:12 EDT
Investigating
We have been investigating reports of a delay in sending outbound emails in North America for accounts using email V2. This will affect Registration, Marketing, Networking & Abstracts. We will provide updates regularly.
Posted Apr 01, 2024 - 17:27 EDT
This incident affected: Email.