Investigating reports of system slowness in North America
Incident Report for Stova
Resolved
This incident has been resolved and all systems are operational.
Posted Sep 05, 2024 - 18:58 EDT
Update
Operational performance has been restored to the NA Platform. Our team continues to investigate the issue to alleviate any further degraded performance.
Posted Sep 05, 2024 - 13:59 EDT
Update
We are continuing to investigate this issue.
Posted Sep 05, 2024 - 13:38 EDT
Investigating
We’re currently investigating reports of system slowness in North America. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Sep 05, 2024 - 13:24 EDT
This incident affected: Web.