Investigating reports of email delays in EMEA with email v2
Incident Report for Stova
Resolved
This incident has been resolved.
Posted Mar 18, 2022 - 11:31 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2022 - 09:31 EDT
Investigating
We have been investigating reports of a delay in sending emails in EMEA using email v2. This will affect Registration, Marketing, Networking & Abstracts. We will provide updates regularly.
Posted Mar 18, 2022 - 08:53 EDT
This incident affected: Email.