Investigating North America server downgraded performance

Incident Report for Stova

Resolved

This incident is resolved now.
Posted Jan 29, 2026 - 03:58 EST

Investigating

We are currently investigating this issue.
Posted Jan 29, 2026 - 03:39 EST
This incident affected: Web.