Email Delays in North America
Incident Report for Stova
Resolved
This incident has been resolved.
Posted May 25, 2023 - 15:53 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 25, 2023 - 15:24 EDT
Update
We are continuing to urgently investigate this issue.
Posted May 25, 2023 - 14:52 EDT
Investigating
We have been investigating reports of a delay in sending outbound v2 emails in North America, this will affect Registration, Marketing, Networking & Abstracts. We will provide updates regularly.
Posted May 25, 2023 - 13:59 EDT
This incident affected: Email.