Degraded Performance accessing Websites and navigating the North American Server

Incident Report for Stova

Resolved

The issue of degraded performance accessing the Websites module and navigating the North American server was resolved now.
Posted Jan 28, 2026 - 19:49 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 28, 2026 - 18:07 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 28, 2026 - 18:02 EST

Investigating

We're experiencing degraded performance accessing the Websites module and navigating the North American server. We are currently looking into the issue. We will continue to post updates throughout the process.
Posted Jan 28, 2026 - 17:46 EST
This incident affected: Web.