We are working to resolve a known issue affecting Stova Clients in North America related to the Websites Module
Incident Report for Stova
Resolved
This incident has been resolved.
Posted Jul 17, 2024 - 15:37 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2024 - 15:12 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 17, 2024 - 15:01 EDT
Investigating
We’re experiencing a service interruption related to the public and admin access of the Websites Module in North America. Our team is aware of the issue and is working to restore service. We will continue to provide updates until full service is restored.
Posted Jul 17, 2024 - 14:38 EDT
This incident affected: Web.