Email Delays for clients using Email V2 via Mailgun
Incident Report for Stova
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 16:25 EDT
Monitoring
Mailgun has implemented a fix and confirmed that they are monitoring their outbound email delivery. We will post additional updates as we have more information.
Posted Jun 09, 2022 - 12:22 EDT
Investigating
We have recently been made aware that our email V2 provider, Mailgun is experiencing a partial service interruption. Due to this interruption this does impact our clients that are using our email V2 services that are routed through the Mailgun services. Our team is monitoring the status with Mailgun and will post an update once we have received confirmation from Mailgun that this matter has been fully rectified.
Posted Jun 09, 2022 - 11:37 EDT
This incident affected: Email.