Email Delays in EMEA
Incident Report for Stova
Resolved
This incident has been resolved.
Posted Oct 12, 2023 - 10:28 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 12, 2023 - 09:24 EDT
Investigating
We have been investigating reports of a delay in sending outbound emails via email v1 in EMEA, this will affect Registration, Marketing, Networking & Abstracts. We will provide updates regularly.
Posted Oct 12, 2023 - 08:37 EDT
This incident affected: Email.