Investigating Email Delivery Issues for select NA Server Mailgun Email V2 Customers
Incident Report for Stova
Resolved
This incident has been resolved.
Posted May 22, 2023 - 09:10 EDT
Monitoring
Email deliverability on the NA Server, related to email V2 is successfully sending. Our team is continuing to monitor.
Posted May 20, 2023 - 15:51 EDT
Update
We are continuing to investigate this issue.
Posted May 20, 2023 - 11:04 EDT
Investigating
We are curently experiencing an issue with emails for select NA server Mailgun Email V2 customers. During this time emails may not be received. We are workig with a third party to identify and resolve this issue.
Posted May 19, 2023 - 19:20 EDT
This incident affected: Email.