Investigating reports of email delays in North America
Incident Report for Stova
Resolved
This incident has been resolved. Due to the nature of this matter, there may be some emails that were not delivered as expected and would need to be resent again. We apologize for the inconvenience.
Posted Apr 19, 2023 - 15:19 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 19, 2023 - 11:26 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 19, 2023 - 11:08 EDT
Investigating
We are currently investigating reports of a delay in sending emails in North America. This will affect Registration, Marketing, Networking & Abstracts. We will provide updates regularly.
Posted Apr 19, 2023 - 09:57 EDT
This incident affected: Email.