"Site has been reported as unsafe" error on Edge
Incident Report for Stova
Resolved
This incident has been resolved. We were able to work with Microsoft to have the site warning removed after review.
Posted Dec 19, 2023 - 11:27 EST
Investigating
We're experiencing an issue with the Microsoft Edge browser where accessing certain event URL's may show a "Site has been reported as unsafe" message. We are currently looking into the issue. We will continue to post updates throughout the process.
Posted Dec 18, 2023 - 17:16 EST
This incident affected: Web.